Thronebreaker: The Witcher Tales Switch NSP XCI NSZ

 
Release Year Jan 28, 2020
Genre Adventure, Role-Playing
Developer CD PROJEKT
Publisher CD PROJEKT
Image Format NSP XCI NSZ
Game Version 1.0.1
Language English [Multi]
Voice English
Required firmware Yes (on 9.1.0, Atmosphere 0.10.2)
Multiplayer no
Age rating 10+
Thronebreaker: The Witcher Tales Box Art
Description:
Thronebreaker is a single player role-playing game set in the world of The Witcher that combines narrative-driven exploration with unique puzzles and card battle mechanics.
Crafted by the developers responsible for some of the most iconic moments in The Witcher 3: Wild Hunt, the game spins a truly regal tale of Meve, a war-veteran and queen of two Northern Realms — Lyria and Rivia. Facing an imminent Nilfgaardian invasion, Meve is forced to once again enter the warpath and set out on a dark journey of destruction and revenge.

Multi Download
Base NSP 4.3 GB GdriveUptoboxMega1Fichier
Update 1.0.1 NSP 51 MB GdriveUptoboxMega1FichierMediaFire
Base + v1.0.1 XCI 4.34 GB Gdrive Uptobox Mega 1Fichier
[IT Language Pack] 1FichierUptobox Facebook Twitter
[ES Language Pack] 1FichierUptobox Facebook Twitter
[ZHS Language Pack] 1FichierUptobox Facebook Twitter
 [PTBR Language Pack] 1FichierUptobox Facebook Twitter
[KO Language Pack] 1FichierUptobox Facebook Twitter
[ZHT Language Pack] 1FichierUptobox Facebook Twitter
[ESMX Language Pack] 1FichierUptobox Facebook Twitter
[JP Language Pack] 1FichierUptobox Facebook Twitter
[PL  Language Pack] 1FichierUptobox Facebook Twitter
[FR  Language Pack] 1Fichier Uptobox Facebook Twitter
 [RU  Language Pack] 1FichierUptobox  
 

20 Replies to “Thronebreaker: The Witcher Tales Switch NSP XCI NSZ”

  1. cannot install Update 1.0.1, the base is OK. tinfoil said I need a higher firmware. my system is 9.1 and Atmosphere 0.10.1

  2. Definitely not a good file, none work, even with 9.1 update and atmosphere update. Garbage – don’t waste your time…pretty much like most of the files on here now

  3. Hello how to install language pack? When I download pl pack i cant install it on TINFOIL / goldleaf… They see it as txt file and open as a hex file…

  4. I cant install the polish language pack, when i try to install it tinfoil instantly spits out an error at 0%. How do i fix this?

Leave a Reply